Router Solution
  ------------------------------------------
Overview
Pro Series Router
Industrial Series Router
Pro Series Network Card
Ind Series Network Card
   
  WAN Monitoring
  ------------------------------------------
WAN monitoring card
WAN monitoring tapper
   
  Technical Support
  ------------------------------------------
Manual Downloads
Technology
Case Study
Technical Notes
FAQ
   

 

 

 
ImageStream - Configuration for Fractional DS3 Point-to-Point

This configuration describes a simple point-to-point fractional DS3 connection from an ImageStream 530 series DS3/E3 (531-DE, 532-DE) port to a Cisco PA-T3 port in a 7xxx series router. On both WAN ports, the address of the WAN port is set to an IP address on a common IP network, and the destination addresses are set to the IP address of WAN port of the unit on the far side of the link.

====ETHERNET===================== 192.168.1.0/24 ===
        |
        | LAN IP: 192.168.1.100
+-------+--------+
|                |
|  ImageStream   |
|   Serial0      |
+-------+--------+
        | WAN IP: 192.168.54.1/30 (255.255.255.252)
        |
       [-] CSU/DSU (integrated on WAN card)
        |
        | DS3 WAN with 6 Mbps
        |
        [-] CSU/DSU (integrated on WAN card)
        |
        | WAN IP: 192.168.54.2/30 (255.255.255.252)
+-------+--------+
|   Serial0      |
|    Cisco       |
|                |
+-------+--------+
        | LAN IP: 192.168.2.200
        |
====ETHERNET===================== 192.168.2.0/24 ===

Before You Start

Be sure to have three separate IP subnets, one for the WAN network and two for the Ethernets connected to the routers. Each WAN port connected to the point-to-point WAN must have it's own IP address from the same IP network. Since they are on the same IP network, they will have the same netmask.

These IP network addresses are given to you by your Internet Service Provider, your leased line carrier, or by ARIN. If you do not plan to connect you network to the Internet, you can use an IP network address set aside for private use. The IP network address for private use can be found in RFC 1597. Most people will use 192.168.0.0 as we have in this example.

Configuring The WAN Ports

In this example, we are going to assume the following:
  • The ImageStream router has an Ethernet IP address of 192.168.1.100 with a netmask of 255.255.255.0
  • The ImageStream router has a WAN IP address of 192.168.54.1 with a netmask of 255.255.255.252
  • The Cisco router has an Ethernet IP address of 192.168.2.200 with a netmask of 255.255.255.0
  • The Cisco router has a WAN IP address of 192.168.54.2 with a netmask of 255.255.255.252
  • The ImageStream router is providing Internet access to the Cisco router.
  • The WAN port on both routers is Serial0.
The IP addresses used in this Technical Note are examples only, you will need to use an IP network given to you by your Internet Service Provider.

ImageStream router

!
version 2.00
!
interface Ethernet0
 ip address 192.168.1.100 255.255.255.0
!
interface Serial0
 description Connection to Cisco router
 encapsulation ppp
 ip address 192.168.54.1 255.255.255.252
 transport ds3
 service-module ds3 timeslots 1-4
 service-module ds3 clock source external
 dsu mode digital-link
 crc 16
!
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
end

Cisco router

!
version 12.1            
service timestamps debug uptime                               
service timestamps log uptime                             
no service password-encryption                              
! 
hostname Router               
! 
ip subnet-zero              
! 
controller T3 2/0                 
cablelength 10
! 
interface FastEthernet0/0                         
 ip address 192.168.2.200 255.255.255.0
 duplex auto            
 speed auto           
!
interface Serial2/0
 bandwidth 6144
 ip address 192.168.54.2 255.255.255.252
 encapsulation ppp
 dsu mode digital-link
 crc 16
 dsu bandwidth 6144
 no scramble
!
ip route 0.0.0.0 0.0.0.0 192.168.54.1
!
ip classless
no ip http server
!
line con 0
line aux 0
line vty 5 15
!
end

Troubleshooting

If the port does not have an "up" status for both hardware and protocol in the interface statistics output (Option 2 from the Main menu) do the following:

If hardware shows "down", check your cable connections and ensure that you have connected to the correct port. If you have connected to the correct port, double-check the telephone company smart jack or other telephone company-installed equipment for your circuit. The smart jack should show no red alarms if the cables are connected. If, after connecting the cables correctly, you have errors on the telephone company equipment, contact your line provider for assistance.

If hardware shows "up", but protocol shows "down", you should see the PPP negotiation and see the status of the WAN port change to up. At this point you should be able to ping the other side.

If you have an external CSU/DSU, put the CSU/DSU into a local loopback. This will cause each packet sent to the CSU/DSU to reflect back to the WAN port. This is for testing only, the line will not function while the CSU/DSU is in a local loopback. If, in the interface statistics detail output for the port, you see transmitted packets immediately received on the same port, then you can determine the following facts:
  1. The WAN port on the router is sending and receiving data.
  2. The cable and connectors between the router and the CSU/DSU are functioning.
  3. The DTE port on the CSU/DSU is functioning.
  4. THE ROUTER IS FUNCTIONING AS IT SHOULD.
If you don't get your packets back immediately on the same interface:
  1. For cards with a software-selectable serial interface, check that you have specified the correct wiring specification (V.35, RS232, RS422/X.21). The "dctype" command is typically set to V.35 (the default) in North America and RS422 in Europe and Asia.
  2. That all cables are securely connected.
  3. Begin swapping hardware, cables, CSU/DSU, etc.
If you get your packets back immediately, but the line protocol status is not "up":
  1. Check the CSU/DSU settings such as clocking, etc. Almost always the CSU/DSU should be set for external clocking. Your line provider typically provides the clock. It's not a bad idea to verify any external CSU/DSU settings with the manufacturer.
  2. Have their telephone carrier test the line. Requesting a hard copy of the test results will often get you a better test.
If the line protocol status is "up" but you can't ping the other side:
  1. Double check settings. Make sure that the IP address for the WAN port on both sides are in the same subnet.
  2. Do a traceroute from your workstation through the local (to you) router to the router in trouble. Then do a traceroute from the router in trouble (assuming you can get to it) back to your workstation. The problem will lie in the gap between the two traceroutes.
  3. Make sure the default gateway is set to the upstream router or the serial device used for the upstream connection, as in our example above on Cisco router.

 

Top